SyntaxHighlighter Evolved용 Lisp 브러시

SyntaxHighlighter Evolved

워드프레스(wordpress)에서 현재 사용하고 있는 문법 강조 플러그인은 SyntaxHighlighter Evolved 입니다. 그런데 HTDP 내용을 정리하려고 보니 그 책에서 사용하는 Scheme은 지원하지 않아 무척 아쉽더군요. 혹시 해서 찾아 보니 사용할 수 있는 브러시가 있어 정리합니다.

미리 준비할 것

  • SyntaxHighlighter Evolved를 먼저 설치해야 합니다.
  • Lisp 브러시는 여기에서 받으면 됩니다.

설치 방법

  1. 워드프레스 플러그인 자동 설치 기능을 지원하지 않아 직접 설치해야 합니다.
  2. 받은 내용을 모두 워드프레스 wp-content/plugins 디렉터리에 복사합니다. plugins 아래에 syntaxhighlighter-lisp 라고 디렉터리를 만들어 넣었습니다.
  3. 설치한 플러그인(Installed plugins) 메뉴에서 SyntaxHighlighter Evolved: Lisp Brush 항목을 활성화합니다.

사용 방법

SyntaxHighlighter Evolved를 통해 문법 강조를 하는 것이므로 사용 방법은 같습니다. 언어에는 lisp, clisp, elisp, emacs-lisp, clojure, scheme을 사용하면 됩니다.

Notes:
1. Lisp를 이용해 MIT에서 만든 교육용 언어입니다.
Lisp를 이용해 MIT에서 만든 교육용 언어입니다.